This content is now out of date.

Visit Our Community

Drill-through and Co display on private reports


I have connected a few reports using co display and drill through,
some of those report I am the owner and on others I have editing permissions.

for some reason the functionality of co display and drill through does not work after activating the report if it is not public.

Please help,
Hi Tal,

I've replicated what you have outlined and have confirmed that this is expected behavior. The application
lets you know this when you are trying to activate these types of reports.

Forum image

If the parent report is public, the co-display or drill through report must also be public. This is an intended security feature and is why it will not let you activate the report.

Please let me know if you have any additional questions regarding this subject.

Thank you,


Thanks for your answer.

I understand the problem when there are some Public and some private reports, but in my case all the reports are private, I am the owner of the parent report, and have editing permissions on the child reports.

and it doesn't work...

is there anther reason maybe?

Hi Tal,

Thank you for providing some clarification. I've just tested this again and will outline my steps;

1 - Created report A and made it private, gave the Admin user Edit rights to this report.
2 - Created report B using Admin user and made the report private.
3 - Created Co-display report using Report B (as Parent Report) and used Report A as Child report.
4 - Successfully saved Co-Display reports.

I've also replicated the steps above using the Drill-Through option and was able to save the report
and the functionality worked.

Please let me know if these steps are accurate. If so, can you provide more details about how the reports 'don't work'? Is there an
error message displayed?

Thank you,



I have exactly the same thing.

When I (as the owner of the report) try the drill through, it does work.
But when I enter from another user (with permissions to the parent and the child reports)
I get in one report-this window on the screen when click to drill through-

Forum image

and in another- it just those not show a drill through option by clicking like I defined.

more than that, when going into editing (from the none owner user but with editing permissions) it shows the Related Reports tab empty from reports.

Hope to find a solution,
Hi Tal,

I still haven't been able to replicate what you have outlined above. My Drill-through reports are still intact when I browse to them as the user with 'edit rights'. I am also able to click the drill through links and they work.

I'm now wondering if you can have Rami submit this issue through the support email channel? It would be good to get the YF logs that are associate with these errors and also get your info.jsp information so we can see what your application details are.

Is this possible? Also, is Rami looking at this issue for you as well?

Please let us know.

Thank you,


Good Afternoon Tal,

Hope you are well,

Sorry for the delay in responding to you, I have been looking in to this issue and I have been unable to replicate the issue. I have created a report that has 2 users assigned to it one as the owner and the other with edit rights, and I have set the users with different access rights and I am able to make changes to the reports.

To enable me to further investigate this issue I need some further information:

If both users are full admin users do you still have the same issue?
What types of reports are the parent and the child reports?
Have you been able to test this with other users, If so what was the outcome?

Is it also possible to get the log files and approx time you tried to access them so that I can see what is reported in the logs for the time stated.

Once I have all this information I can try and replicate the issue again.