This content is now out of date.

Visit Our Community

Default filter selection for IOS Yellowfin app

Hi Yellowfin,

I am using yellowfin app in iPhone. When I am open this dashboard in iPhone,
it showing Incomplete filters message,
it is not displaying any output until & unless I select the filter value.

How to set default filter value to see the output when page loads for IOS Yellowfin app?

I am using Yellowfin 7.1 on AWS.

Kindly post your answer here or Email me (below I have mentioned Email ID).

Thank You,
Hi Shivagange,

Can you please double check your Filter formatting on the Data screen of the report that
is on the Dashboard?

Forum image

Can you also review the following link to our Wiki that reviews Filter formatting.

Filter Formatting

Let us know, if after reviewing this information and double checking your setup, if you
are still facing this issue with getting the Default Dashboard Filters to display upon loading
while using the IOS YF app.

Thank you,


Hi kyle,

Yes, my dashboard reports are containing same filter format settings(Filter setting.jpg), which you have posted in forum.

Still I am facing same issue(Mobile ScreenShot.PNG). I can�t able to set the default filter value in YF app, it showing same error (Incomplete Filter).

Even when I am going to �edit report� then also it is showing same error(Incomplete Filter).
Here I have attached Screenshot please check it out.

Kindly post your answer here or Email me (below I have mentioned Email ID).

Thank You,
Hello Shivagange,

Unfortunately, none of your images have come through on the Forum. Can
you try to attach them again, or send them in to and
reference the subject of this forum post?

It might also be helpful to obtain the YF log files that are relevant to this message
that you are getting.

Thank you,

Hi Kyle,

I'm Shivagange's colleague.

This is with reference to the e-mail conversation to with Support Case ID#: 195789
Subject: Yellowfin[195789]|- Default filter selection for IOS Yellowfin app;

I am circling back to you on the issue which we're having with the iOS app and here're the details you've asked for:

1.Are you using the free trial of YF with AWS?

YES, we're on 1Year free trail on AWS

2.What build of YF are you using?


Please provide us the solution for the same.

Here're some more details:

System Information
Application Version: 7.1
Build: 20140827
Java Version: 1.7.0_55
Operating System: Linux 3.13.0-29-generic (amd64)

iOS App Information

Device: iPhone4
iOS Version: 7.1.2
YF App version: 7.1

Device: iPad2
iOS Version: 8.3
YF App version: 7.1

PFA inline screenshot for License Information of YF on AWS

Forum image

Thanks and Regards,
Prateek A
Hello Prateek,

Yes, Shivagange did provide the information that I requested. He sent it via email and it created a case and we handled
it out of that communication channel. Which brings up a good point. Going forward, we would prefer that you and your company post general 'how to' questions in the forum. For ALL other issues (system errors, complicated issues) please
send those in to our support email, -
And, please do not submit the same requests through both channels as this quite often leads to delays and confusion in the support team handling your requests. Thank you for understanding and adhering to our support policies.

In terms of this request, I have responded to both you and Shivagange with the following information;

We have been unable to replicate this issue on a new build of YF. It was been determined that you are presently testing this on the free trial of AWS, which actually uses an older build of the product. This is a downside of the free trial, which is that you miss out on the new patches that contain bug fixes and system improvements. I believe your company is also actually a client and may be using a newer build of YF. If so, you should be able to test this and confirm that the filter settings on a dashboard to indeed apply when the dashboard is viewed on a tablet.

Please feel free to share your thoughts.

Thank you,


Hi Kyle,

This is to confirm that, dashboard filter settings indeed applied when viewed on a tablet with same iOS version and device using the following builds:20150107(on free AWS) & 20150624(on licensed local machine).

Is there a possible way in upgrading to latest builds on free AWS, like from 20140827 to 2015xxxx and higher, if so guide us.

Thank You,

Hello Prateek,

I've reached out again to our level II / Dev team on this question of upgrading an instance of the free trial offer of AWS. This is what I was offered - since you are also a paying client (and also testing the free offer) you should have access to the upgrade patches on the website and therefore, you should be able to patch your free instance, just as if it were your 'paid for' instance. You just need to apply the patch.

Have you tried this? If so and you are experiencing issues, please provide the details and we can attempt to assist you. If not,
can you try it and let us know how it goes?

Thank you,


Hi Kyle,

This issue is still not resolved.

This case only arises when: Mandatory value is set on the filter.

When we will allow Omit and set a default value, it works fine.

But we more of the times, we dont want the Omit Option. In that case, we have a set a mandatory field. As soon as mandatory is selected, only on iOS and Android, filters are not missing (though default values are set.

Kindly help us. We are desperate for this solution