This content is now out of date.

Visit Our Community

Creating date hierarchy with .csv import

In trying to add year and month fields using the Date Hierarchy Calculated Field functionality, I run into problem. When I get to the 'Please Select a Field to Base this Field on' I get no options to select from. The only difference from other times I have done this is I am using a csv file. Any ideas?

Forum image
Hi Tom,

Thanks for the question. I just tested this, and date hierarchy functionality behaves as expected when data is imported into the view via CSV.

If you don't mind me asking, which date hierarchy calculated field did you pull in to your view?

If you pulled in the 'Date' field, it would be expecting your field to be in timestamp format.

If you are building a traditional Year, Quarter, Month, Date hierarchy what you should do is pull in the Year, Quarter, Month calculated fields in from the Date Hierarchy section and then base all of these fields on your specific date field.

Afterward, you could then create your date hierarchy drill down structure. Here is a link to a useful tutorial video that explains how to create a date hierarchy etc.

View Date Hierarchy Fields


View Drill Down Hierarchies

Hopefully this information has been helpful. Please let me know if you need further clarification. Have a great day!

Kind Regards,

Hey Dustin,

Thanks for responding on this, but I have not resolved it yet. I have tried this pulling in Year Start Date, Month Start Date, Year, Month and Quarter all with the same result.

I have the date field set up as MM/dd/yyyy, but it continues to not show up an as option to base one of the calculated date fields on. Actually, no fields show up, still. Is there another date format I should be trying.

Other thoughts?

Hi Tom,

I'm sorry to hear that you are still running into trouble... Could you let us know which version/build of Yellowfin you are currently on so that we can attempt to replicate what you are experiencing using your build?

Thanks in advance.

Kind Regards,


Forum image

Here you go...

Hi Tom,

Thanks for sending in the additional info. I just wanted to let you know that I was able to replicate what you are experiencing, and I have opened up a defect for this issue so that our developers can take a look/resolve it. The Task ID is #205369.

The good news is that there is a work around, as this doesn't seem to occur when a CSV is uploaded into Yellowfin using the view importer instead of the report builder.

If you haven't done this before, here is a link to our wiki explaining how to import a .CSV via the view:

View Builder CSV Import

Hopefully this is good news for you. Please feel free to let me know if you have any questions or concerns.

Have a great day!

Kind Regards,