This content is now out of date.

Visit Our Community

Admin role has gone missing from the YF database

Yesterday 6 Jan 2016, all admin users including system admin reverted to being a report consumer. Upon checking the various database tables, we found that YFADMIN role was missing from the table ORGROLE. We also found that all the admin users had their admin role end dated yesterday. We don't know how this happened.

However, we did try re-inserting the YFADMIN role back into the database (using the values as per a copy of our production db that we have in another environment). Now the system admin user is getting the error "You don't have the appropriate access to log on to this role." Other users with admin roles also are getting the same error.

We made sure we reset the passwords of these users (including system admin) as well as made sure they have an end date of 9999-12-31 for their admin role in staffmemberrole table and also for their user in ipclass table, but we still get this error.

We checked the logs when one of these users attempted to log on and the SQL shown for the selectStaffMemberRoles() function returns something using SQL straight into the database, but the logs show a result saying "No roles found for logging on user".

Luckily, the scheduled reports are still running even after the problem has occurred.

Can you advise what else we should look at or try in order to resolve this issue?

Any help would be appreciated.

Good Morning Caitriona,

Hope you are well,

We are currently looking into the case you logged and will respond to you via that.